Actualiza cuanto antes Ubuntu para corregir este fallo en Systemd

Ubuntu es el sistema operativo basado en Linux más conocido y utilizado en toda la red. Este sistema operativo, desarrollado por Canonical, busca llevar la experiencia Linux a todos los usuarios interesados en ella, ya tengan conocimientos avanzados en sistemas operativos como sean usuario sin experiencia previa. Además, igual que el resto de los sistemas Linux, este sistema operativo es bastante más seguro que otros como Windows. Más seguro, pero no invulnerable ya que, cada poco, aparecen distintos fallos de seguridad en este sistema operativo que pueden poner en peligro a los usuarios como el que se acaba de descubrir en el componente systemd.

Mientras que hace una semana Ubuntu ya se ha visto afectado por una vulnerabilidad, Stack Clash, que permitía a cualquiera conseguir permisos de root en cualquier sistema operativo fácilmente, hace algunas horas, Canonical volvía a preocupar a los usuarios haciendo pública una vulnerabilidad en systemd, el demonio de arranque del sistema operativo, la cual puede permitir a un atacante causar un error de denegación de servicio sobre el sistema e incluso llegar a ejecutar código en la memoria del mismo.

Este fallo de seguridad ha sido registrado como CVE-2017-9445 y se encuentra en el componente systemd-resolved, el componente encargado de gestionar las peticiones DNS que hacemos a través de Internet. De esta manera, si un pirata informático envía al sistema una respuesta DNS maliciosa especialmente creada para explotar la vulnerabilidad, el sistema puede caer en estado de error y bloquearse e incluso es posible ejecutar aplicaciones o código directamente en la memoria del sistema.

Las dos últimas versiones de Ubuntu, es decir, 16.10 y 17.04, son vulnerables a este importante fallo de seguridad, aunque, por suerte, Canonical ya ha lanzado el correspondiente parche para solucionarlo. Además de la distribución principal, otras derivadas de ellas, como Kubuntu, Lubuntu, Xubuntu, Kylin, Cloud y las versiones Server también están afectadas por este mismo fallo.

Cómo proteger nuestro Ubuntu de esta vulnerabilidad en systemd

Como hemos dicho, las dos versiones afectadas por esta vulnerabilidad son Ubuntu 16.10 y 17.04. La última versión LTS 16.04 (ni la anterior 14.04, que aún no llevaba systemd) no está afectada por este fallo de seguridad. Como Canonical ya ha liberado un parche para solucionar esta vulnerabilidad, lo único que debemos hacer es actualizar nuestro sistema operativo para quedar así protegidos frente a este fallo. Para ello, desde un terminal simplemente ejecutaremos:

  • sudo apt update && sudo apt upgrade

Instalaremos todos los paquetes que haya disponibles. Una vez finalice el proceso de actualización, nuestros sistemas quedarán actualizados a las versiones 231-9ubuntu5 y 232-21ubuntu5, quedando ya protegidos de estas vulnerabilidades y pudiendo seguir conectándonos a Internet de la forma más segura posible, al menos, hasta que vuelva a aparecer un nuevo fallo de seguridad.

Entre WannaCry, NotPetya y todas las vulnerabilidades que se están descubriendo para todos los sistemas operativos recientemente, está claro que no son buenos tiempos para la seguridad y que lo primero y más importante para no caer víctima de piratas es mantener nuestros sistemas operativos y nuestras aplicaciones totalmente actualizadas, reduciendo la probabilidad de terminar siendo víctima de piratas informáticos.

Fuente: redeszone

Anuncios


Categorías:Software Libre - Linux

Etiquetas:, ,

Responder

Por favor, inicia sesión con uno de estos métodos para publicar tu comentario:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: